Platform Performance Degradation

Incident Report for One Legal System Status

Resolved

This issue has been resolved.
Posted Mar 26, 2025 - 13:17 PDT

Identified

We are aware of slower than usual platform performance. Our team is actively working on resolving this issue. We apologize for any inconvenience and appreciate your patience while we work to improve performance.
Posted Mar 26, 2025 - 12:56 PDT
This incident affected: platform.onelegal.com.