Mendocino eFiling Submission Delay
Incident Report for One Legal System Status
Resolved
This issue has been resolved.
Posted Apr 25, 2024 - 22:19 PDT
Identified
We are currently experiencing a payment issue that is causing delays in eFiling submission to court. Due to the issue, submissions will not be processed to court until resolved.
Posted Apr 25, 2024 - 18:58 PDT
This incident affected: California eFiling (Mendocino County).