Imperial Count Superior Court Experiencing Technical Issues

Incident Report for One Legal System Status

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 13:58 PDT

Investigating

A technical issue is preventing some users from submitting filings in Imperial County Civil eFiling courts. The Court’s technology vendor has identified the problem and is working to implement a fix. There is no ETA for resolution at this time, we will share updates as we receive them.
Posted Aug 14, 2025 - 12:46 PDT
This incident affected: California eFiling (Imperial County).