We are currently observing ongoing delays in our physical order processing which may cause slowness or temporary interruptions when handling and updating physical service orders — including service of process, physical court filing, and courtesy copy deliveries. These delays are related to a broader AWS (Amazon Web Services) outage impacting multiple providers, including One Legal. AWS is reporting continued recovery across affected systems, and we are seeing gradual improvements. However, some order delays may persist through the remainder of the day. Our team is closely monitoring performance and will provide updates as soon as full stability is confirmed. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 13:48 PDT
Investigating
We are currently experiencing intermittent issues with our AWS service provider that may impact order submissions. As a result, some orders may experience temporary delays in processing or transmission.
Our team is actively monitoring the situation and working with AWS to ensure normal operations are restored as quickly as possible. We appreciate your patience and understanding during this time.
Thank you for your patience and understanding.
Posted Oct 20, 2025 - 11:46 PDT
This incident affected: Physical Services (Court Filing, Service of Process, Delivery).