Billing Center Payment Declined
Incident Report for One Legal System Status
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 12:08 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2021 - 09:38 PST
Identified
We've received reports of users getting a payment decline message when attempting to pay their invoice. We've identified an issue with our payment processing vendor and we are actively working with them to resolve this issue.
Posted Feb 17, 2021 - 15:09 PST